# Не работает подключение IMAP по SSL: [SSL: SSLV3_ALERT_HANDSHAKE FAILURE sslv3 alert handshake failure (ssl.c:1017)
# Симптомы

При попытке настроить IMAP с шифрованием SSL не удается проверить подключение.
Отображается ошибка:

```txt
[SSL: SSLV3_ALERT_HANDSHAKE FAILURE sslv3 alert handshake failure (ssl.c:1017)
```

# Решение

Разрешите подключение по менее надежным шифрам SSL:

1.  Отредактируйте файл /root/swarmica/.env, чтобы он содержал вот такие строки:
    ```bash
    IMAP_SSL_CUSTOM_CONTEXT=true
    IMAP_SSL_CUSTOM_CIFERS=DEFAULT
    ```
2.  Перезагрузите Swarmica:
    ```bash
    docker compose down
    docker compose up -d
    ```

Если на сервере IMAP используются самоподписанные сертификаты, тогда необходимо дополнительно выполнить инструкции из статьи [#650: Получение почты по IMAP с самоподписанными сертификатами](https://support.swarmica.com/article/ru/650-poluchenie-pochty-po-imap-s-samopodpisannymi-sertifikatami.html)

# Причина

Сервер использует устаревшую версию шифров SSL, которая по умолчанию отключена в Swarmica для обеспечения большей безопасности.