# Перестала ходить входящая почта
# Симптомы

1.  Настроено SMTP  перенаправление почты с адреса вида `support@company.tld` -> `support@support.company.tld`, где company.tld - это почтовый сервер (может быть Gmail, VK, Яндекс или локальный), а support.company.tld - это Swarmica
2.  Почта не доходит до тикета
3.  Если заглянуть в почтовый ящик , `support@company.tld` то письма там есть
4.  В почте отправителя баунсы&#x20;
    Delivery Status Notification (Delay)
    454 4.7.1 : Relay access denied
5.  В логах постфикса на сервере ошибки вида:
    `Oct 02 19:04:42 support postfix/smtpd[147]: NOQUEUE: reject: RCPT from unknown[79.137.243.76]: 454 4.7.1 <support@support.swarmica.com>: Relay access denied; from=<msudyin@swarmica.com> to=<support@support.swarmica.com> proto=ESMTP helo=<fallback20.i.mail.ru>`

# Решение

Добавить IP адреса почтового провайдера (например  [IP Адреса Gmail](https://support.google.com/a/answer/60764?hl=en) ) в переменную SMTP\_NETWORKS и перезагрузить postfix:

```txt
vim .env
grep SMTP_NETWORKS .env
SMTP_NETWORKS=35.190.247.0/24,64.233.160.0/19,66.102.0.0/20,66.249.80.0/20,72.14.192.0/18,74.125.0.0/16,108.177.8.0/21,173.194.0.0/16,209.85.128.0/17,216.58.192.0/19,216.239.32.0/19,2001:4860:4000::/36,2404:6800:4000::/36,2607:f8b0:4000::/36,2800:3f0:4000::/36,2a00:1450:4000::/36,2c0f:fb50:4000::/36,172.217.0.0/19,172.217.32.0/20,172.217.128.0/19,172.217.160.0/20,172.217.192.0/19,172.253.56.0/21,172.253.112.0/20,108.177.96.0/19,35.191.0.0/16,130.211.0.0/22
docker-compose up -d
```

**ВНИМАНИЕ! ЭТА КОМАНДА ПЕРЕЗАПУСТИТ ВСЕ ПРИЛОЖЕНИЯ - БУДЕТ ДАУНТАЙМ**

# Причина

Входящая почта обрабатывается postfix, который по умолчанию не разрешает соединение с внешних IP адресов

## Для других провайдеров

Такая ошибка может быть и для других провайдеров. Например, для VK Workspace нужно настроить вот такие SMTP\_NETWORKS:

```txt
79.137.243.0/24,94.100.180.215/32,94.100.180.216/32,217.69.139.215/32,217.69.139.216/32
```

В общем случае нужно смотреть в SPF запись домена, **с которого** настроено перенаправление, и добавлять эти сервера