# Как повторно "забрать" письма с почтового сервера по IMAP?
# Симптомы

Если почта не была обработано Swarmica по какой-либо причине, и необходимо повторно обработать те письма, которые не добавились в тикеты:

# Решение

*   Сделать резервную копию "поломанной" почты на всякий случай:

```shell
docker exec -it --env-file .env swarmica-cron-1 bash
cp logs/failed_email/*.eml uploads/

```

*   Запустить повторный принудительный опрос IMAP сервера:

```shell
docker exec -it --env-file .env swarmica-cron-1 bash
for MAIL in `ls uploads/*.eml`; do python manage.py parse_incoming_email support@domain.tld -f $MAIL; done
```

#